Go to footer

Mini cuts out after travelling about a kilometre

All your technical, mechanical, electrical, exterior, interior, I.C.E. and even baby seat questions go in here. We've a lot of Mini gurus on the forum who'll be glad to help out with whatever technical probllems your Mini is having, or if you'd like to upgrade/modify yours we'll try to help too.

Moderator: MiniMpi


Mini cuts out after travelling about a kilometre

Postby allweatherman » Thu Jun 30, 2016 11:35 pm

Any thoughts about 1995 mini sidewalk Spi Mini cuts out after travelling about a kilometre starts again travel on and cuts out again. Same when stationary will start and run then just cut out.
Thew fuel pump sounds if its running OK. What do think I should I should be looking at.

thanks

Richard
allweatherman
Just Joined!
 
Posts: 2
Joined: Wed Jun 29, 2016 11:12 pm


Re: Mini cuts out after travelling about a kilometre

Postby irlmin » Fri Jul 01, 2016 6:01 pm

Sounds like a distributor problem , possible crank angle sensor .look also for poor wiring connections .
G
Image
User avatar
irlmin
MCOI Founding Member
 
Posts: 6004
Joined: Thu Jan 01, 1970 1:00 am
Location: Peoples Republic of Cork


Re: Mini cuts out after travelling about a kilometre

Postby MiniMpi » Fri Jul 01, 2016 10:37 pm

Another possible thing to check is that the coil is faulty.
Friend of mine had this before on his classic Mini and it would stay fine for about a kilometre as well, the coil would overheat and once cooled it would drive for another kilometre.
Ferg
MiniMpi
Membership Secretary
 
Posts: 7238
Joined: Thu Jan 01, 1970 1:00 am
Location: Driving my Volcanic Orange F56 Cooper Petrol


Re: Mini cuts out after travelling about a kilometre

Postby allweatherman » Tue Jul 26, 2016 10:21 pm

Hi thanks for all the advise, done as suggested - changed the coil, checked the fuses, repaired broken/frayed wires, cleaned out the fuel lines, checked the battery/alternator, cleaned the dizzy and checked all the sensors. Still no joy eventually got my son who is a Honda guru to look at it, he put a Volt Meter on the fuel pump even though it was starting he diagnosed that the pump was faulty. Looked at mini spares just the pump alone €100 or €200 for the full unit, didnt fancy spending that if it wasnt the pump. Anyway my guru son looked at the pump on line and said the Honda prelude pump is exactly the same which he had. So took out petrol tank put in the Honda prelude pump in and away the car went no problems. I had to get a pump as the MPI model is 3 bar and my one is 1 bar SPI, didnt want to take a chance I would burn out the cat.
allweatherman
Just Joined!
 
Posts: 2
Joined: Wed Jun 29, 2016 11:12 pm


Return to Board index

Return to Technical Questions and General Mini Help

Who is online

Users browsing this forum: No registered users and 1 guest